Advanced search FAQ Register Login

It is currently Mon Jan 22, 2018 7:08 am

 

Postby sshum » Wed Jan 10, 2018 5:46 pm

Hello,

I've ordered quite a few Pi Tops V2 for our school, but one seems to be faulty.

It seems to be the Hub board. The screen sometimes doesn't turn on or sometimes flicker. I have unplugged/ reconnected everything that I can, but it still isn't working. I though it might have been the SD card, so I did re-image the SD card too. I've attached a photo to show what it looks like sometimes when the screen is on.

My Order ID: #215204

Thank you

sshum
n00b

Posts: 3

Joined: Wed Jan 10, 2018 5:39 pm

Attachments

IMG_20180110_163447.jpg

IMG_20180110_163447.jpg (4.25 MiB) Viewed 82 times

Postby Dave » Thu Jan 11, 2018 9:38 am

If you feel comfortable disassembling the unit and checking that the internal connections are seated correctly, then please do so. This won't affect your warranty.

If not, I'm happy to arrange a return for the unit so we can repair or replace as needed.

Please let me know how you would like to proceed.

Dave
ModMyPi

User avatar

Posts: 2078

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Postby sshum » Thu Jan 11, 2018 9:40 am

Even if I remove the stickers that say 'Warranty void if removed'?? I was going to unplug and reconnect them to see if that's the issue but stopped when I saw the stickers. I will happily check internal connections if that sticker isn't true.

sshum
n00b

Posts: 3

Joined: Wed Jan 10, 2018 5:39 pm

Postby Dave » Thu Jan 11, 2018 9:54 am

sshum wrote:Even if I remove the stickers that say 'Warranty void if removed'?? I was going to unplug and reconnect them to see if that's the issue but stopped when I saw the stickers. I will happily check internal connections if that sticker isn't true.


Yeah that's not a problem, we will still honour the warranty if checking the internals doesn't resolve the issue.

Note: For others reading this post, please be aware that your warranty will become void if those stickers are broken WITHOUT prior consent from ModMyPi (if the unit was purchased from us) or Pi-Top themselves.

Dave
ModMyPi

User avatar

Posts: 2078

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Postby sshum » Mon Jan 15, 2018 10:09 am

Hello,

I checked the connections on the board this morning and no luck. The screen isn't turning on just like before.

How do I arrange to return this item?

Thanks

sshum
n00b

Posts: 3

Joined: Wed Jan 10, 2018 5:39 pm

Postby Dave » Mon Jan 15, 2018 10:10 am

sshum wrote:Hello,

I checked the connections on the board this morning and no luck. The screen isn't turning on just like before.

How do I arrange to return this item?

Thanks


I'll have sales contact you shortly to arrange the return for a replacement.

Dave
ModMyPi

User avatar

Posts: 2078

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Who is online

Users browsing this forum: No registered users and 12 guests

Board index

The teamDelete all board cookies • All times are UTC [ DST ]