Advanced search FAQ Register Login

It is currently Sun Feb 18, 2018 7:04 pm

 

Postby dnsolo » Tue Feb 13, 2018 4:55 pm

I've recently purchased 2 x 7 inch Official RP3 Touchscreens from your website but currently having trouble getting either of them to work.

They don't display anything when the Pi boots up? All my ribbon connections etc look correct.

Here's my setup:

Raspberry Pi 3 Model B
Separate power cables going to both the Touch Screen and the Pi.
Boots up from USB drive (running latest and updated version of Raspian)

Have tried everything possible to get these Touch Screens working but no success so far.

Any advice would be much appreciated :)

dnsolo
n00b

Posts: 2

Joined: Tue Feb 13, 2018 4:45 pm

Postby Dave » Tue Feb 13, 2018 5:06 pm

Hmm the fact you can't get either of them working would indicate an issue with the setup as opposed to faulty units.

I would start by ditching the USB boot and go back to the "normal" sd card booting.

I would also only use 1 power supply to power the whole thing, either power to the display and usb cable from display to Pi power. Or power to the Pi, and use the gpio jumper wires to power the screen.

Dave
ModMyPi

User avatar

Posts: 2151

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Postby dnsolo » Thu Feb 15, 2018 1:34 pm

Hello Dave,

I found the problem, it was with the DSI cable, I can get the TouchScreen to work by 'twisting' the DSI connector cable.
This doesn't seem right to me and risks damaging the cable but it does work :)

Please see photo below:

Photo1.jpg

DSI Cable Twisted into position

Photo1.jpg (270.93 KiB) Viewed 108 times

dnsolo
n00b

Posts: 2

Joined: Tue Feb 13, 2018 4:45 pm

Postby Dave » Thu Feb 15, 2018 2:52 pm

The touch screens are designed to have the Pi mounted to the rear of them, and so the ribbon cable connectors have been orientated accordingly. If you are not mounting the Pi to the back of the display, then yes, the ribbon cable needs to be twisted.

ribbon.jpg

ribbon.jpg (710.62 KiB) Viewed 105 times

Dave
ModMyPi

User avatar

Posts: 2151

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

Board index

The teamDelete all board cookies • All times are UTC [ DST ]