Advanced search FAQ Register Login

It is currently Wed Jan 24, 2018 2:34 am

 

Postby warmtoast » Sat Dec 30, 2017 11:47 pm

Hey, I've been having some issues with my TEMPer Gold "Original" USB Temperature Sensor, part of order 215935.

I've been playing with it since its arrival a week or so ago and always come up with the same issue.

Unless I restart my RPi3 it always polls the same temperature. I've tried this on two RPi3s running the latest version of Raspbian with all the firmware and distro updates applied.

This seems to be a known issue by the people who have written the code which forms part of your usage instructions:

https://github.com/padelt/temper-python ... -290753783

I've also found it mentioned across the internet, for example:

http://www.thermohid.co.uk/ (ctrl-f: 'sticky')

I've gone as far as side-stepping the python driver and playing around with the C version that the python is based on:

https://github.com/petervojtek/usb-thermometer

But alas, same problem.

Just wondering if you've had any other reports on this issue? I'm still keen to use this product for my home thermostat control that I'm working on but I'm coming to the conclusion the device which I received is bust.

I don't know if a replacement would be possible? Rather frustratingly I've thrown out all the packaging that it came with so I'm not sure how your returns policy would apply.

Thanks for your time,
Colin

warmtoast
n00b

Posts: 4

Joined: Sat Dec 30, 2017 11:19 pm

Postby Dave » Tue Jan 02, 2018 10:31 am

Hi Colin,

This is the first report we have had of this issue, but that doesn't mean it's not a known issue. As you've pointed out you aren't the only one to experience this.

Looks like you ordered a few of those sensors. Do you experience the same problem with them all?

Dave
ModMyPi

User avatar

Posts: 2085

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Postby warmtoast » Tue Jan 02, 2018 5:06 pm

Cheers for getting back in touch over the new year!

The other two sensors went to a friend at work, we're doing similar projects just now so went for a bulk order.

I do want to have a shot with one of his once I've returned to the office. If those two work fine and the third which I took is still faulty would an exchange be possible?

Thanks for your time!

warmtoast
n00b

Posts: 4

Joined: Sat Dec 30, 2017 11:19 pm

Postby Dave » Wed Jan 03, 2018 10:13 am

warmtoast wrote:Cheers for getting back in touch over the new year!

The other two sensors went to a friend at work, we're doing similar projects just now so went for a bulk order.

I do want to have a shot with one of his once I've returned to the office. If those two work fine and the third which I took is still faulty would an exchange be possible?

Thanks for your time!


Yes of course! Let me know how the other two are working and if they are, I will get a replacement issued.

Dave
ModMyPi

User avatar

Posts: 2085

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Postby warmtoast » Wed Jan 10, 2018 4:06 pm

Hey!

So I borrowed the other USB TEMPers of my colleague and I've have had them plugged in for a couple of days now and I'm not seeing the issues I was with the device I had previously been testing.

Capture.PNG

Capture.PNG (37.21 KiB) Viewed 23 times



They both still "flat spot" from time-to-time as has been witnessed elsewhere http://www.thermohid.co.uk/ThermoHIDstickiness.png - but at least it's no longer just sticking with one value for hours on end.

Can I commence an exchange with yourselves for another USB TEMPer? As stated previously I am missing the packaging/documentation that it came with - hopefully this still isn't an issue.

Thanks for all your time!

warmtoast
n00b

Posts: 4

Joined: Sat Dec 30, 2017 11:19 pm

Postby Dave » Wed Jan 10, 2018 5:35 pm

Not a problem, sales will be in touch shortly to arrange a replacement.

Dave
ModMyPi

User avatar

Posts: 2085

Joined: Wed Jul 22, 2015 11:36 am

Forum Administrator & Technical Support

Postby warmtoast » Wed Jan 10, 2018 5:53 pm

Amazing - Cheers!

warmtoast
n00b

Posts: 4

Joined: Sat Dec 30, 2017 11:19 pm

Who is online

Users browsing this forum: No registered users and 3 guests

Board index

The teamDelete all board cookies • All times are UTC [ DST ]