We have had some user's reporting the following symptoms when using the UPS PIco:

* UPS PIco Not Functioning e.g. No shutdown when power removed
* Battery Not Charging

The majority of these were solved by following every step of the install procedure outlined below:

https://github.com/modmypi/PiModules/wi ... stallation

Please ensure that installation is completed on a brand new up to date distribution of Raspian (https://www.raspberrypi.org/downloads/raspbian/), and that all packages are installed including the email broadcasting package.

Ensure that there are no other devices or scripts running on the Pi at all when investigating UPS PIco function.

Ensure that you are using a stable and tested power supply

If you're still experiencing bugs when using the UPS PIco, these can usually be solved by updating the firmware on the device to the latest version:

UPS PIco Latest Firmware Version 0x38

0x38_UPS_PIco_HV3.0_main.zip

(24.2 KiB) Downloaded 460 times



Firmware Update Tool

9600_picofuHV3.0.zip

(5.7 KiB) Downloaded 472 times



FirmwareManual

03_0x38_W_UPS PIco HV3.0.pdf

(4.51 MiB) Downloaded 480 times



Please follow the firmware update procedure outlined here, following every step:

https://github.com/modmypi/PiModules/wi ... are-Update

You can find alternative and preliminary releases on the PiModules Forums here:

http://www.forum.pimodules.com/viewtopi ... =25&t=6200.

If you're still experiencing issues, then please raise a post in technical support.

Please Note. Old UPS PIco scripts will not work with newer PIco's as many registers have been changed. Please ensure that you only use scripts and code available on the UPS PIco Github repo - https://github.com/modmypi/PiModules/wiki or that officially released by ModMyPi or PiModules.

-- Jake