Unable to connect via wifi...

Electronics being social! What could possibly go wrong?
Post Reply
Delebel
n00b
Posts: 2
Joined: Fri Feb 24, 2017 8:30 pm

Unable to connect via wifi...

Post by Delebel » Fri Feb 24, 2017 8:45 pm

Hi I'm a newbie at this pie zero game so I hope I can still ask the right questions. I've purchase a wifi dongle that enumerates on my PC as a Realtek RTL8188cu but if fails to get me connected from the pie zero. I'm using the Raspbian-jessie dated 2017-01-11 and it comes up with a graphical environment called Pixel. Anyway the dongle is seen by the system since I can see my network SSID but entering the shared key when prompted does nothing and I see a message wlan0 not associated? I've surfed several help forums and sites but all attempts like editing the wpa_supplicant.conf file has not changed any of the symptoms. Now I could buy another dongle directly from a site that claims its Pie zero compatible but a google search with "linux wifi" seems to indicate my dongle at least has a valid driver available so before I spend I'd like to know if in fact the RTL8188 is not operational with my setup as it stands.

Thanks ahead of time if you can provide some insight into my issue. Denis

User avatar
Dave
ModMyPi
Posts: 2901
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Unable to connect via wifi...

Post by Dave » Mon Feb 27, 2017 9:48 am

Hmm, if the WiFi dongle shows the SSID's of any networks in range then I would have thought it should be able to connect to them fine.

Looks like there is an issue with using that RTL8188 as an Access Point, but should work out of the box otherwise.

Maybe format your SD card and re-install Rasbian via NOOBs - http://s.modmypi.com/noobs

And double check you've entered the correct password ;)
Forum Administrator & Technical Support

Delebel
n00b
Posts: 2
Joined: Fri Feb 24, 2017 8:30 pm

Re: Unable to connect via wifi...

Post by Delebel » Mon Apr 03, 2017 10:03 pm

I tried the Noobs route but I was unsuccessful at getting it going. At this stage I think it would be simpler just to get a new pie zero with built in Wifi. As for the Raspian setup I figured out my network is only using the old WEP encryption algorythm as my Android TV box will not work with the WPA flavour of encryption. Perhaps then the Pie Zero with Wifi may also not connect out of the box. So again before I jump to buy I think I would be prudent to figure out my connection problems now. I must brush up on the linux environment as its become obvious that failing to have exactly the right setup, configuration at the prompt level WILL BE necessary.

Thanks for reponding my faith that I can migrate from my custom Pic upc boards running C to the Pie Zero environment is fading fast. : (

Regards Denis

BMS Doug
31337
Posts: 273
Joined: Tue Sep 08, 2015 3:55 pm
Location: London

Re: Unable to connect via wifi...

Post by BMS Doug » Tue Apr 04, 2017 4:21 pm

Could you try creating your SD Card using Pi-Bakery? http://www.pibakery.org/
you can set a WIFI ssid and password when you setup the card.

I was struggling to get WIFI working on a Pi Zero W and this worked for me.
Doug.

Volunteer Moderator.

TimothyCoash
n00b
Posts: 7
Joined: Fri Jan 25, 2019 5:14 am
Location: Denmark
Contact:

Unable to connect via wifi

Post by TimothyCoash » Fri Feb 01, 2019 2:02 pm

My present setup is as described. If I were to move to the apartment, Id still want to keep my present network. Question is, how do I hook up to their wifi and keep my network some wired, some not?

Post Reply