HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
serene02
Initiated
Posts: 21
Joined: Sat Jun 10, 2017 8:56 pm

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by serene02 » Wed Jun 14, 2017 6:42 pm

Hi Dave. I did give the screen a go on my work pc about an hour ago. I think the problem is the back light as I had a bit longer so let left the screen on for 20 minutes, the banding was still evident but suddenly the display went dark. I could see the image extremely faint so could possibly be a backlight issue which kind of makes sense from the flickering.

Anyway all packaged up now, thanks again.

J

serene02
Initiated
Posts: 21
Joined: Sat Jun 10, 2017 8:56 pm

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by serene02 » Wed Jun 21, 2017 9:29 am

Order ID: #196317

Hi Dave, any update on this screen?


All the best
J

User avatar
Dave
ModMyPi
Posts: 2856
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by Dave » Wed Jun 21, 2017 9:48 am

Looks like we've received the returned unit, so I'll get it tested and a replacement sent out today for you :)
Forum Administrator & Technical Support

serene02
Initiated
Posts: 21
Joined: Sat Jun 10, 2017 8:56 pm

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by serene02 » Wed Jun 21, 2017 9:57 am

Wow, thanks Dave, that's great fella.

J

User avatar
Dave
ModMyPi
Posts: 2856
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by Dave » Wed Jun 21, 2017 10:14 am

Ok I've tested the screen but I'm unable to reproduce the fault you described.

I've tested it on both a Raspberry Pi and my Windows 10 computer on which the screen displays perfectly fine with no flickering.

This could indicate that the fault may be with the power supply. There should have been an Official Raspberry Pi Universal PSU supplied with the screen, however this wasn't returned so I'm unable to test it.

What I'll do is get the screen packed up and shipped back to you, but I'll include another PSU (I will test the PSU with the screen before sending it).

Could you also confirm that when you had the screen setup, you had both the POWER micro USB and TOUCH micro USB cables plugged in?

I'll wait to hear back from you before sending the unit back.
Forum Administrator & Technical Support

serene02
Initiated
Posts: 21
Joined: Sat Jun 10, 2017 8:56 pm

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by serene02 » Wed Jun 21, 2017 11:06 am

It came with two power supplies. That's strange, I thought I'd sent them both back, one was inside the main box with the screen, the other in a small white box in the main packaging. Could you check as I've checked here and I don't have it here.

I had the Raspberry Pi (official) adapter plugged into the wall which connected to the power slot on the screen, the other micro usb was connected to my PC and the touch port on the display. Does the touch one also need plugging in to the wall as I had it powered via usb?

Anyway if this unit is good I really do apologise for wasting your time.

Many thanks Dave.
J

User avatar
Dave
ModMyPi
Posts: 2856
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by Dave » Wed Jun 21, 2017 11:58 am

Oh I do apologise, the PSU was indeed buried in there under the packaging!

Tested again with the supplied PSU and it still seems to be working correctly.

The TOUCH does not need external power, it simply gets its power directly from the USB port. I'm not sure how well it'll work if plugged into a USB hub though. Might be worth plugging it directly into a USB port on the computer/raspberry pi.

I did notice that if the TOUCH USB was removed, then the screen would turn off, however this is consistent with the other screens we have.

Lastly, this only applies to the Raspberry Pi, but was the /boot/config.txt edited to add the required screen settings? (settings included on a flyer in the box) as this includes the correct resolution and framerate used by the screen.

On your computer, are you able to check the framerate? It needs to be set to 60 Hz.

I'll get the screen returned now so you can try the above, and we'll go from there.

Not wasting my time at all, we are here to help :)
Forum Administrator & Technical Support

serene02
Initiated
Posts: 21
Joined: Sat Jun 10, 2017 8:56 pm

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by serene02 » Wed Jun 21, 2017 12:31 pm

Yeah, I've tested it on all my PC's straight to the USB ports, all running at the correct resolution and 60hz. The banding was subtle on lighter backgrounds but on the blue windows 10 desktop and generally darker backgrounds it was really noticeable on all the PC's I tested. How odd.

But yes, send it back I will give it another bash. Let me know if you need anything for posting back to me Dave.

All the best
J

User avatar
Dave
ModMyPi
Posts: 2856
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by Dave » Wed Jun 21, 2017 1:16 pm

Hmmm very odd indeed!

Nope don't need anything from you, got all your details from the order id.
Forum Administrator & Technical Support

serene02
Initiated
Posts: 21
Joined: Sat Jun 10, 2017 8:56 pm

Re: HDMI 10.1" 1280x800 (IPS) Touch Screen & Case - MMP-0471

Post by serene02 » Wed Jun 21, 2017 3:18 pm

OK, thank you.

J

Post Reply