PROBLEM: UPS Pico & official touchscreen

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
tomasby
n00b
Posts: 4
Joined: Mon Apr 09, 2018 1:42 am

PROBLEM: UPS Pico & official touchscreen

Post by tomasby » Thu Jun 28, 2018 8:31 pm

Have the official 7" touchscreen, and a UPS Pico 3.

When I changed from powering the RPi from the screen, via the GPIO, to using a USB cable (ie from screen to RPi), the UPS does no longer power the screen. As soon as I cut the wall power the screen goes black. Earlier the screen was on for as long as the computer.

Is this the way it is supposed to work, or do I have a problem with the USB cable? Any other options?

(I prefer to not use the GPIO, as I have limited space in that direction, and it is nicer to have a USB cable near the screen.)

/Tomas
Last edited by tomasby on Fri Jun 29, 2018 1:35 pm, edited 1 time in total.

User avatar
Dave
ModMyPi
Posts: 2649
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: PROBLEM: USP Pico & official touchscreen

Post by Dave » Fri Jun 29, 2018 1:06 pm

Which model Raspberry Pi are you using?

Could you post a picture of how you have everything connected please
Forum Administrator & Technical Support

tomasby
n00b
Posts: 4
Joined: Mon Apr 09, 2018 1:42 am

Re: PROBLEM: UPS Pico & official touchscreen

Post by tomasby » Fri Jun 29, 2018 1:27 pm

It's 3B I believe. I do not have it set up at the moment, and do not have the jumper cables available, but first it was two jumper wires from the screen PCB to the GPIO, as shown here:

https://files1.element14.com/community/ ... y_stp7.jpg

Then I removed those wires and used a USB - micro USB cable, from the full size USB connector on the screen PCB to the normal Raspberry micro USB power port, with the external power connected to the screen micro USB port. This is also from the instructions somewhere, cannot find it right now.

When running on external power there is no noticable difference, but on battery power, with the USB cable, the screen is not on.

/Tomas

User avatar
Dave
ModMyPi
Posts: 2649
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: PROBLEM: USP Pico & official touchscreen

Post by Dave » Fri Jun 29, 2018 1:37 pm

Ah ok I see your problem!

You have the mains power going to the screen first and then to the Pi. When you pull the power from the screen, there is no power then going to the screen and it turns off :) The PIco supplies power to the Pi over the GPIO pins so the Pi stays on. The Pi's Micro-USB port is used for power IN only, it will not output power, plus the "PWR OUT" USB on the screen PCB will only output power, and will not accept power in.

What you should do, if you don't want to power the screen via GPIO cables is plug the full size USB cable into one of the Raspberry Pi's USB ports, and then the Micro-USB end into the Micro-USB power port "PWR IN" of the screen PCB.

That way the Pi will provide power to the screen over USB.
Forum Administrator & Technical Support

tomasby
n00b
Posts: 4
Joined: Mon Apr 09, 2018 1:42 am

Re: PROBLEM: UPS Pico & official touchscreen

Post by tomasby » Fri Jun 29, 2018 2:04 pm

Ok, that makes sense. I think it is back to GPIO.

Post Reply