Faulty UPS Pico battery

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
Nixus
n00b
Posts: 5
Joined: Tue May 15, 2018 3:59 pm

Faulty UPS Pico battery

Post by Nixus » Tue May 15, 2018 4:05 pm

Hi.

A while back we ordered 2 UPS pico HV3.0B HAT Stack Plus.
After everything was set up on one board we tested the UPS functionality and the RPi died immediatly everytime, reviewing everything a bunch of times I thought about changing the battery to the other one, and then it worked flawlessly.

Switched back the battery and then the RPi died immediatly again.

Switched to the other battery everything is ok.

Checked with the status script with the faulty battery and the bat power would not go beyond 3.1 V
But the battery that worked went up to 4.1-4.2

So our conclusion is that the battery must be faulty.

How can we get an exchange?
We also wanted to buy 8 more RPi:s and 8 more ups, but the pico ups arent in stock no more.
Are they returning soon?

User avatar
Dave
ModMyPi
Posts: 2649
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Faulty UPS Pico battery

Post by Dave » Wed May 16, 2018 8:47 am

Could you post your order please.

Have you charged the battery that's not working? If you plug the non-working battery into the PIco, plug the PIco on to your Raspberry Pi and leave the Pi powered on through mains power for a few hours, this should charge the battery. You should see the charge led on the PIco illuminate.

We are hoping to have more stock in by the end of the month.
Forum Administrator & Technical Support

Nixus
n00b
Posts: 5
Joined: Tue May 15, 2018 3:59 pm

Re: Faulty UPS Pico battery

Post by Nixus » Wed May 16, 2018 12:49 pm

Hi.

We have had it plugged in for a few hours. Something I noticed today was that the battery voltage drops even if its plugged in.
And the leds are blinking. UPS every ~600ms, BAT on, CHG on.
Then after a while the CHG turns off for ~ 2 seconds and only BAT is on.

This only happens with the faulty battery.

Order ID: #223701
Date Added: 12/03/2018

Here are some screens about the pico status script.

Image

Image

User avatar
Dave
ModMyPi
Posts: 2649
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Faulty UPS Pico battery

Post by Dave » Wed May 16, 2018 2:19 pm

Thanks for the update.

Does indeed sound like the battery is faulty.

For your reference, the LED lights are indicating:

UPS LED - Blinking @ 400ms = PIco is powered from mains power
@ 1200ms - PIco is powered from battery

BAT LED - ON = Battery is below warning threshold
- OFF = Battery above warning threshold
(For LiPO Battery 3.6V, For LiFePO4 2.95V)

CHG LED - ON = Battery charging
- OFF = Battery not charging

I will have a replacement battery shipped out today for you.
Forum Administrator & Technical Support

Nixus
n00b
Posts: 5
Joined: Tue May 15, 2018 3:59 pm

Re: Faulty UPS Pico battery

Post by Nixus » Tue Jun 05, 2018 11:17 am

Hi again.

Was this shipped as I have not received it yet.

User avatar
Dave
ModMyPi
Posts: 2649
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Faulty UPS Pico battery

Post by Dave » Tue Jun 05, 2018 11:44 am

Nixus wrote:
Tue Jun 05, 2018 11:17 am
Hi again.

Was this shipped as I have not received it yet.
I can confirm the item has been shipped, but is being held up by customs due to the battery contents.
This parcel has been identified as containing items suspected of being prohibited or dangerous. The contents are being examined. If found to be compliant, the parcel will be delivered to the intended recipient.
Once they have examined the contents, the parcel will be on its way to you, so should be with you soon.
Forum Administrator & Technical Support

Nixus
n00b
Posts: 5
Joined: Tue May 15, 2018 3:59 pm

Re: Faulty UPS Pico battery

Post by Nixus » Tue Jun 05, 2018 12:57 pm

Ok, thank you for info :)

Post Reply