Pi Zero W died after connecting usb ethernet

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
Protazy
n00b
Posts: 2
Joined: Thu May 17, 2018 8:20 pm

Pi Zero W died after connecting usb ethernet

Post by Protazy » Thu May 17, 2018 8:44 pm

Hi there,
I received Pi zero W yesterday with case and a white 1 port usb network and 3 port usb hub. The pi was working ok until I connected the white usb ethernet/usb hub.

Pi booted up - green led (act) was blinking, connected the usb ethernet, pi powered down, disconnected ethernet, pi powered up, tried to connect the ethernet again, pi died for good.

I ruled out power adapter as a potential root cause of the problem. I've another Pi3 which I'm connecting to the same power adapter, 3b powers up
with no issues, zero W doesn't. Didn't risk to connect usb ethernet to 3b. The area of white raspberry logo is quite hot when power cable is plugged in. Pi does not show anything on screen when connected to monitor, 3b with the same power, hdmi cable and monitor works fine.

Is there anything I can do to resurrect my pi? If not how can I get replacement Pi and working usb/ethernet hub?

My order number 230244

Cheers

User avatar
Dave
ModMyPi
Posts: 2399
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Pi Zero W died after connecting usb ethernet

Post by Dave » Fri May 18, 2018 8:25 am

I'm really sorry about that!

Could you just try formatting the SD card and re-installing Rasbian, just in case this is all coincidence, and the SD card is actually faulty.

We have a simple guide here - http://s.modmypi.com/noobs

If that does breath life back into your Pi, could you try the USB ethernet again.

If none of the above works I'll be more than happy to arrange a replacement Pi Zero and USB Ethernet hub.
Forum Administrator & Technical Support

Protazy
n00b
Posts: 2
Joined: Thu May 17, 2018 8:20 pm

Re: Pi Zero W died after connecting usb ethernet

Post by Protazy » Fri May 18, 2018 6:51 pm

Hi Dave,
thanks for the advice, unfortunately that didn't help.

Where do I send it back?

User avatar
Dave
ModMyPi
Posts: 2399
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Pi Zero W died after connecting usb ethernet

Post by Dave » Mon May 21, 2018 9:11 am

Protazy wrote:
Fri May 18, 2018 6:51 pm
Hi Dave,
thanks for the advice, unfortunately that didn't help.

Where do I send it back?
Thanks for trying that, it was worth a shot!

I will have sales contact you now to arrange a replacement.
Forum Administrator & Technical Support

Post Reply