Wifi Dongle (high Gain version) not working

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
Psfletcher
n00b
Posts: 5
Joined: Thu Nov 12, 2015 9:42 pm

Wifi Dongle (high Gain version) not working

Post by Psfletcher » Mon Jul 30, 2018 6:25 pm

Hi All,
I have one of the previous Wifi Dongles with the external high gain antenna (its now been updated) bought from Mod My Pi.
Its still working brilliantly as a Access Point, unfortunately what's not working nicely is the SD Card which is running the RPi.
So i am trying to build a new setup (Access Point) with the same dongle and a Ras Pi v3 to give it a bit more power, but I can't get hostapd to activate the AP part of the dongle it keeps on saying there is a error.

Does anyone know if there is any drivers or prereq's for the old dongle I need to try?
I'm sure there used to be a modmypi tutorial for this, but it doesn't seem to be around anymore?

I'm looking for some direction really, I've already tried 2-3 different web sites methods of getting the Ras Pi AP to work, but they always come back with the same error in hostapd. The actual device is not with me, but if I can find a good idea of what the problem could be I can get the device back.

If not I'm quite happy to look for a alternative dongle (with a external antenna) which will work and I can build something brand new and replace like for like. But ideally i'd like to reuse the existing dongles.

I look forward to hearing your thoughts!

Thanks

Pete

User avatar
Dave
ModMyPi
Posts: 2649
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Wifi Dongle (high Gain version) not working

Post by Dave » Tue Jul 31, 2018 8:07 am

Are you able to post a picture of the dongle in question, just so we know exactly which dongle you are referring to?
Forum Administrator & Technical Support

Psfletcher
n00b
Posts: 5
Joined: Thu Nov 12, 2015 9:42 pm

Re: Wifi Dongle (high Gain version) not working

Post by Psfletcher » Thu Aug 02, 2018 12:36 pm

Hi,
yes i can, but what is the best way of doing this?
I can e-mail you if you pm me an address?

Thanks

Pete

User avatar
Jake
ModMyPi
Posts: 1442
Joined: Thu Aug 27, 2015 3:57 pm

Re: Wifi Dongle (high Gain version) not working

Post by Jake » Thu Aug 02, 2018 4:51 pm

If you post a reply, and add the picture as an attachment, you'll be able to place it in line.

There is a little guide here on how to add pictures to posts - viewtopic.php?f=33&t=207
Forum Administrator & Technical Support

Psfletcher
n00b
Posts: 5
Joined: Thu Nov 12, 2015 9:42 pm

Re: Wifi Dongle (high Gain version) not working

Post by Psfletcher » Mon Aug 06, 2018 12:35 pm

Hi,
Picture attached, sorry I didn't see the "attachments" tab next to the options tab!
Hopefully this will help!

Pete
Attachments
dongle.png
dongle.png (608.68 KiB) Viewed 219 times

User avatar
Jake
ModMyPi
Posts: 1442
Joined: Thu Aug 27, 2015 3:57 pm

Re: Wifi Dongle (high Gain version) not working

Post by Jake » Mon Aug 06, 2018 2:09 pm

Thanks - so you had AP mode working correctly previously and now it is not?

I wonder - is it possible for you to set up the dongle + AP on a "regular" PC to check the function first? You then know it's an issue with the dongle, or with the Pi set up.

What's the hostapd error you're getting?

-- Jake
Forum Administrator & Technical Support

Psfletcher
n00b
Posts: 5
Joined: Thu Nov 12, 2015 9:42 pm

Re: Wifi Dongle (high Gain version) not working

Post by Psfletcher » Mon Aug 06, 2018 3:02 pm

Hi,
Easily no, the actual device is 3 hours away!
I know its not the Dongle its something to do with the os/software.
As its currently working, but on a Ras 1 which must be about 2-3 years old in firmware now.

When i was trying to get a new one to work, it was a Ras 3, with up to date everything.

So really the question is, should everything have worked? And is there any known steps that this dongle needs to ensure it works?
I followed this tutorial the first time from memory, or it may have been one from your site.
https://thepi.io/how-to-use-your-raspbe ... ess-point/
and compared it to this one.
https://www.raspberrypi.org/documentati ... s-point.md

I followed these tutorials with the Ras 3 and had errors.
But if you can't think of any issues, the quickest thing is to get a new HI Gain Dongle from your site and recreate rather than getting the old ones back.

Hope that makes sense?

Thanks

Pete

User avatar
Jake
ModMyPi
Posts: 1442
Joined: Thu Aug 27, 2015 3:57 pm

Re: Wifi Dongle (high Gain version) not working

Post by Jake » Tue Aug 07, 2018 8:36 am

Yes, it makes sense! If you're confident that the dongle is functioning correctly then to answer below. . .
Psfletcher wrote:
Mon Aug 06, 2018 3:02 pm

So really the question is, should everything have worked?
Yes, but then again maybe not :mrgreen: . There have been a lot of changes from your revision to the Pi 3.

Just to check - The Pi 3 has on board WiFi. It's not something "simple" like you're setting up the wrong wireless interface for the AP?
Psfletcher wrote:
Mon Aug 06, 2018 3:02 pm

And is there any known steps that this dongle needs to ensure it works?
Not as far as I'm aware. That the dongle you have utilises the Ralink RT3070 chipset, and the newer version uses the same chipset (RT3070), just in a higher power package for more range.

I'll be happy to take a look at your hostapd.conf file (with passwords removed), and I can try to set one of the new dongles up here to see if I can get it working?

-- Jake
Forum Administrator & Technical Support

Post Reply