Error -110 usb on rpi zero w

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
fedormil
n00b
Posts: 6
Joined: Mon Apr 16, 2018 10:30 am

Error -110 usb on rpi zero w

Post by fedormil » Sat Sep 01, 2018 6:39 pm

ID заказа: #218696
Raspberry Pi Zero Wireless WH
Good evening! Yesterday there was a problem with usb, when installing the drive through otg, a restart occurred and usb-flash was no longer recognized. Error code

Code: Select all

[   32.083021] Indeed it is in host mode hprt0 = 00021501
[   32.403000] usb 1-1: device descriptor read/64, error -110
[   32.523143] Indeed it is in host mode hprt0 = 00021501
[   32.792999] usb 1-1: new full-speed USB device number 3 using dwc_otg
[   47.923062] Indeed it is in host mode hprt0 = 00021501
[   48.132956] usb 1-1: device descriptor read/64, error -110
[   52.019757] pcm512x 1-004d: No SCLK, using BCLK: -2
[   63.376624] Indeed it is in host mode hprt0 = 00021501
[   63.632980] usb 1-1: device descriptor read/64, error -110
[   63.753048] usb usb1-port1: attempt power cycle
lsusb

Code: Select all

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
When usb flash is connected, the LED is on, but there is no registration.
On the other rpi zero w all works fine. What could be the problem? Is the connector faulty?

User avatar
Dave
ModMyPi
Posts: 2608
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Error -110 usb on rpi zero w

Post by Dave » Mon Sep 03, 2018 8:40 am

Have you tried formatting the SD card and reinstalling the OS?
Tried a different USB port on the host?
Tried a different USB cable/connector?
Forum Administrator & Technical Support

fedormil
n00b
Posts: 6
Joined: Mon Apr 16, 2018 10:30 am

Re: Error -110 usb on rpi zero w

Post by fedormil » Mon Sep 03, 2018 12:11 pm

Yes, I tried everything: the other OS, and different flash usb, and another otg.This error occurs even, when there are no usb devices.

User avatar
Dave
ModMyPi
Posts: 2608
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Error -110 usb on rpi zero w

Post by Dave » Mon Sep 03, 2018 1:17 pm

Ok, can you test the USB port by doing the following please:

1. Power up the Raspberry Pi normally (NOT via OTG)
2. Plug a micro-USB to USB adaptor into the Pi
3. Connect a USB keyboard and/or mouse and see if the device works

This will establish if USB port on the Pi is faulty or not.

If it works, it could be something to do with the computer you are plugging the Raspberry Pi into via OTG.

Also, are you using the latest version of Rasbian, and have you configured the Pi correctly for OTG connection?
Forum Administrator & Technical Support

fedormil
n00b
Posts: 6
Joined: Mon Apr 16, 2018 10:30 am

Re: Error -110 usb on rpi zero w

Post by fedormil » Mon Sep 03, 2018 2:10 pm

I work with moode v.4.2. How it should be configured otg?

User avatar
Dave
ModMyPi
Posts: 2608
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Error -110 usb on rpi zero w

Post by Dave » Mon Sep 03, 2018 3:30 pm

fedormil wrote:
Mon Sep 03, 2018 2:10 pm
I work with moode v.4.2. How it should be configured otg?
Sorry I'm not sure what you mean?

Have you tried my previous suggestion about testing the USB port?
Forum Administrator & Technical Support

fedormil
n00b
Posts: 6
Joined: Mon Apr 16, 2018 10:30 am

Re: Error -110 usb on rpi zero w

Post by fedormil » Mon Sep 03, 2018 7:33 pm

Dave wrote:
Mon Sep 03, 2018 1:17 pm
Ok, can you test the USB port by doing the following please:

1. Power up the Raspberry Pi normally (NOT via OTG)
2. Plug a micro-USB to USB adaptor into the Pi
3. Connect a USB keyboard and/or mouse and see if the device works

This will establish if USB port on the Pi is faulty or not.

If it works, it could be something to do with the computer you are plugging the Raspberry Pi into via OTG.
Tried, as you suggested. Power at the mouse appeared, but the mouse does not work in the system tray. But she had not worked with this connection before.
I do not connect rpi zero to the computer, it works as an audio player with Justboom Amp Hat Zero, through which it receives power.
Dave wrote:
Mon Sep 03, 2018 1:17 pm
Кроме того, вы используете последнюю версию Rasbian, и у вас правильно настроен Pi для подключения OTG?
How should Pi be set up correctly for the otg connection?

fedormil
n00b
Posts: 6
Joined: Mon Apr 16, 2018 10:30 am

Re: Error -110 usb on rpi zero w

Post by fedormil » Mon Sep 03, 2018 8:17 pm

Set up usb - Enable dwc2 driver in BOOT/config.txt

Code: Select all

dtoverlay=dwc2
Reboot.
dmesg

Code: Select all

[    9.683118] dwc2 20980000.usb: EPs: 8, dedicated fifos, 4080 entries in SPRAM
[    9.684009] dwc2 20980000.usb: DWC OTG Controller
[    9.684087] dwc2 20980000.usb: new USB bus registered, assigned bus number 1
[    9.684429] dwc2 20980000.usb: irq 33, io mem 0x20980000
[    9.706576] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    9.706601] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.706611] usb usb1: Product: DWC OTG Controller
[    9.706621] usb usb1: Manufacturer: Linux 4.14.54+ dwc2_hsotg
[    9.706631] usb usb1: SerialNumber: 20980000.usb
[    9.710659] hub 1-0:1.0: USB hub found
[    9.711602] hub 1-0:1.0: 1 port detected
[   56.632925] usb 1-1: device descriptor read/64, error -110
[   72.063001] usb 1-1: device descriptor read/64, error -110
[   72.183069] usb usb1-port1: attempt power cycle

User avatar
Dave
ModMyPi
Posts: 2608
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Error -110 usb on rpi zero w

Post by Dave » Tue Sep 04, 2018 8:38 am

Oh I see, sorry I thought you were plugging the Pi into your computer via USB.

Ok yes, if mouse isn't working when it sounds like the unit is faulty.

I will have our sales team contact you to arrange a replacement. Sorry for the misunderstanding and delay!
Forum Administrator & Technical Support

Post Reply