NewLink 4 port USB Hub not working

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
dburgreen
n00b
Posts: 1
Joined: Sat Nov 03, 2018 3:17 am

NewLink 4 port USB Hub not working

Post by dburgreen » Sat Nov 03, 2018 3:24 am

Invoice ID: 243089
Version of Raspberry pi: NA
Part Name: NewLink USB 4 port Hub
Fault: No communication between connected devices
Troubleshooting: different cables, various use cases, using both powered from adapter and bus powered, restarting devices being used

Hi - I've tried just about everything with this. Different cables, different use cases.
Began by connecting it to my Organelle which is essentially a raspberry pi made into a hardware musical instrument.
After spending quite a bit of time there I tried to use it to connect an external hard drive to my macbook pro.

I'm 100% certain this is defective and would like to arrange a return, not interested in troubleshooting any further as I also was being helped by an engineer for the troubleshooting already completed.

Please let me know how to arrange the return so that I can have the shipping covered.

Thanks.

User avatar
Dave
ModMyPi
Posts: 2690
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: NewLink 4 port USB Hub not working

Post by Dave » Fri Nov 09, 2018 9:58 am

I'm so sorry about the delay in response.

I will have a replacement issued for you today.
Forum Administrator & Technical Support

Post Reply