Issue with buttons and joystick

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
Jakeyb
n00b
Posts: 3
Joined: Fri Dec 28, 2018 2:24 pm

Issue with buttons and joystick

Post by Jakeyb » Sat Dec 29, 2018 10:10 am

Hi my order no is 247378

I have two issues. One is joystick down does not work, I’ll follow advice as per

viewtopic.php?f=33&t=2000&p=8597&hilit=Picade#p8597

But it is currently installed and doesn’t create a tx

The other is that the volume buttons don’t work. The working buttons cause the tx light on the picade to light twice. Once on press and once on release. The volume buttons are creating only a “release flash” and Retropie does not recognise it in button setup.

I swapped the buttons and the wires over the problem appears to be with the board not the buttons or wire



Any advice?


Thanks

Jake

User avatar
Dave
ModMyPi
Posts: 2850
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Issue with buttons and joystick

Post by Dave » Wed Jan 02, 2019 9:32 am

I have contacted Pimoroni for some advice, I will let you know as soon as I hear back from them.
Forum Administrator & Technical Support

Pimoroni_Matt
n00b
Posts: 13
Joined: Wed Jan 18, 2017 9:56 am

Re: Issue with buttons and joystick

Post by Pimoroni_Matt » Thu Jan 10, 2019 9:43 am

Hi Jakeyb,

Sorry to hear that! I'm guessing you've checked all the wiring and connections between the joystick and the HAT, do you hear a click from the microswitch on the joystick at all?

The volume buttons aren't passed through to the Pi, they work on the HAT directly as that should be what's controlling the audio - do you hear sound, but the volume controls aren't working, or do you not get any sound through?

Cheers,

Matt

Jakeyb
n00b
Posts: 3
Joined: Fri Dec 28, 2018 2:24 pm

Re: Issue with buttons and joystick

Post by Jakeyb » Sat Jan 12, 2019 6:46 pm

Hi,

The problem with the joystick is resolved by removing one of the plastic plates. It seems pretty robust.

The issue with the "volume ' buttons is only that the hat is apparently not receiving a signal. I am not particularly trying to control the volume. The picade software does not recognise the button press during setup and, as mentioned, only one light flash occurs rather than two (for press and depress). I swappewd the button wires and the issue remains. Ie the buttons and thw wires are behaving as expected. So i have two not working buttons

On a different note- i am configuring the system and there is no sound from the speakers. When i plug in earphones to the HAT i do get sound. I amnot sure if this is a software config error or a hardware error. Is there a way to diagnose the hardware?

Thanks,

Pimoroni_Matt
n00b
Posts: 13
Joined: Wed Jan 18, 2017 9:56 am

Re: Issue with buttons and joystick

Post by Pimoroni_Matt » Mon Jan 14, 2019 9:07 am

Hi Jakeyb,

Glad you got the joystick working. Just wondering, which Picade board do you have? Is it the separate PCB, or is it one of the HATs?

Jakeyb
n00b
Posts: 3
Joined: Fri Dec 28, 2018 2:24 pm

Re: Issue with buttons and joystick

Post by Jakeyb » Wed Jan 16, 2019 10:19 am

Pimoroni_Matt wrote:
Mon Jan 14, 2019 9:07 am
Hi Jakeyb,

Glad you got the joystick working. Just wondering, which Picade board do you have? Is it the separate PCB, or is it one of the HATs?
Hi, actually good call. it is the seperate PCB

Post Reply