Access to serial port when Pico HAT is installed

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
mikcatta
n00b
Posts: 4
Joined: Wed Mar 28, 2018 1:51 pm

Access to serial port when Pico HAT is installed

Post by mikcatta » Tue May 07, 2019 3:51 pm

I can read my serial GPS fine, without the Pico HAT connected. However, as soon as it is connected, access to the GPS on ttyAMA0 results in nadda.

The documentation suggests that the serial port is only utilised during boot and f/w upgrade.

I have tried "sudo i2cset -y 1 0x6b 0x02 0x00" to disable the serial port on the Pico, without any joy.

The GPS is connected to pins 8 & 10 on the 40 way header. The documentation says:-

The UPS PIco HV3.0 is equipped with 2 serial ports. One of them is connected directly
to the Raspberry Pi ® Serial Port, and the second one is available for user applications.
Both Serial Ports are full programmable, and the data rate can be set by user, as also
can be enabled or disabled.


I am supposed to be using a port from the Pico ?

mikcatta
n00b
Posts: 4
Joined: Wed Mar 28, 2018 1:51 pm

Re: Access to serial port when Pico HAT is installed

Post by mikcatta » Tue May 07, 2019 8:56 pm

Upgraded the Pico UPS f/w to 0xE3 and serial comms is now working from the GPS.

Yeah!

User avatar
Dave
ModMyPi
Posts: 2936
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Access to serial port when Pico HAT is installed

Post by Dave » Wed May 08, 2019 8:49 am

mikcatta wrote:
Tue May 07, 2019 8:56 pm
Upgraded the Pico UPS f/w to 0xE3 and serial comms is now working from the GPS.

Yeah!
Glad you figured it out!
Forum Administrator & Technical Support

mikcatta
n00b
Posts: 4
Joined: Wed Mar 28, 2018 1:51 pm

Re: Access to serial port when Pico HAT is installed

Post by mikcatta » Wed May 08, 2019 9:44 am

Reply from Loannis suggests this is a known issue.

https://github.com/modmypi/PiModules/issues/43

Post Reply