Faulty USB hub

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
jeannotalpin
n00b
Posts: 1
Joined: Wed May 08, 2019 2:43 pm

Faulty USB hub

Post by jeannotalpin » Wed May 08, 2019 2:53 pm

Hello,
I have just received the New Link 4 Port USB Hub - UK 5V 2A (MMP-0182), in Order ID #259244, but it doesn't seem to work as expected.

When plugged to the raspberry Pi, (3B) my USB hard drive (powered by USB) is not detected (not even by the kernel ---Raspbian distribution). I tried on my Ubuntu laptop, and the USB drive is working fine when plugged directly to the computer but again is not detected when plugged to the powered USB hub. In fact not a single USB device is detected when connected to the powered USB hub (I tried a externally powered drive, a pen drive).
I would like a refund for the USB hub and the UK/EU plug adaptor.

Thanks.
Jean.

User avatar
Dave
ModMyPi
Posts: 2936
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: Faulty USB hub

Post by Dave » Wed May 08, 2019 3:14 pm

Could you please confirm you have used the supplied USB-B cable to connect the HUB to the Pi/Laptop.

The USB-B cable supplied plugs into the USB port next to the power port on the HUB, the square looking port.
Forum Administrator & Technical Support

Post Reply