UPS pico automatially power off and some questions

Need some help with your shiny new breakout board, or something not working right? Let us help you here!
Post Reply
xload
Initiated
Posts: 21
Joined: Mon Jun 10, 2019 9:47 am

UPS pico automatially power off and some questions

Post by xload » Tue Jun 11, 2019 9:07 am

Hello,

When I power on my raspberry from external power the following leds are on: UPS, BAT FAN and I can read the RTC and i2c registers, after 3 or 5 minutes only CHG led is on and I can not read anything.

What is happening?

I only need to use UPS pico as an ups and run my Pi as a standalone system when I'm traveling.

Best regards and a lot of thanks in advance

User avatar
Dave
ModMyPi
Posts: 2965
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: UPS pico automatially power off and some questions

Post by Dave » Wed Jun 12, 2019 8:31 am

Could you post your order ID please.

Could you also post a picture of the setup please?

What voltage/current is your external power source?
Forum Administrator & Technical Support

xload
Initiated
Posts: 21
Joined: Mon Jun 10, 2019 9:47 am

Re: UPS pico automatially power off and some questions

Post by xload » Wed Jun 12, 2019 8:46 am

Hello Dave,

I ordered at rs-online.

My power supply is 5V 2A.

At pic the battery is full charged, all leds are off.
https://imgur.com/a/57RohdJ

User avatar
Dave
ModMyPi
Posts: 2965
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: UPS pico automatially power off and some questions

Post by Dave » Wed Jun 12, 2019 8:57 am

Ok, firstly, do you have the original battery that came with the pico. I would suggest using this until you get it working, then you can change the battery.

Secondly, have you followed the installation guide - https://github.com/modmypi/PiModules/wi ... stallation - It's important that ALL steps are done in the guide.

Please also make sure you are using Raspbian OS.
Forum Administrator & Technical Support

xload
Initiated
Posts: 21
Joined: Mon Jun 10, 2019 9:47 am

Re: UPS pico automatially power off and some questions

Post by xload » Wed Jun 12, 2019 9:01 am

A lot of thanks Dave, I will try with a "clean" Raspbian version.

xload
Initiated
Posts: 21
Joined: Mon Jun 10, 2019 9:47 am

Re: UPS pico automatially power off and some questions

Post by xload » Wed Jun 12, 2019 11:34 am

In a clean Raspbian system seems to work, I can unplug the power supply, but after some minutes the raspberry power off, what is happening?

User avatar
Dave
ModMyPi
Posts: 2965
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: UPS pico automatially power off and some questions

Post by Dave » Wed Jun 12, 2019 11:38 am

xload wrote:
Wed Jun 12, 2019 11:34 am
In a clean Raspbian system seems to work, I can unplug the power supply, but after some minutes the raspberry power off, what is happening?
There is a battery run time setting.

Take a look at the program registers - https://www.modmypi.com/download/pimodu ... r-list.pdf

Specifically: 0x6b 0x01 "bat_run_time"

You'll need to set that to 0xFF to disable the timer, so the pi will stay power all the time whilst on battery.
Forum Administrator & Technical Support

xload
Initiated
Posts: 21
Joined: Mon Jun 10, 2019 9:47 am

Re: UPS pico automatially power off and some questions

Post by xload » Thu Jun 13, 2019 10:56 am

A lot of thanks Dave, now It works as I want.

Now I'm working with the other registers, I'm sure that I will ask something again :)

User avatar
Dave
ModMyPi
Posts: 2965
Joined: Wed Jul 22, 2015 11:36 am
Contact:

Re: UPS pico automatially power off and some questions

Post by Dave » Fri Jun 14, 2019 8:29 am

xload wrote:
Thu Jun 13, 2019 10:56 am
A lot of thanks Dave, now It works as I want.

Now I'm working with the other registers, I'm sure that I will ask something again :)
:lol:

No worries, glad you are up and running!
Forum Administrator & Technical Support

Post Reply